Home » Developer & Programmer » Precompilers, OCI & OCCI » OCI on 8.1.7
OCI on 8.1.7 [message #93677] Mon, 07 October 2002 07:31 Go to next message
Vanisri Yalamanchili
Messages: 4
Registered: October 2002
Junior Member
Hi,

Eventhough I have been working on Oracle for a while I never worked with OCI. We have Oracle 817 databases here and we recently got a project that needed to be developed in C using OCI to talk to Oracle. Where would I get the OCI libraries. I read somewhere that OCI comes bundled with Oracle server. But what if the development server is different from the data server. How would I install OCI on the development server. Any help is greatly appreciated.

Thanks
Vani
Re: OCI on 8.1.7 [message #93683 is a reply to message #93677] Thu, 10 October 2002 00:20 Go to previous message
msnail
Messages: 1
Registered: October 2002
Junior Member
I think the oci does not bundled with oracle server,it doesn't like pro*c
You can compile the oci programe with the right oracle's own including files and library files.
the compile condition likes this:
INCS = -I$(ORACLE_HOME)/rdbms/include -I$(ORACLE_HOME)/rdbms/demo -I$(ORACLE_HOME)/plsql/public -I$(ORACLE_HOME)/network/public -I$(ORACLE_HOME)/rdbms/public
LIBS = -L. -L$(ORACLE_HOME)/lib/ -L$(ORACLE_HOME)/rdbms/lib -lclntsh -lpthread
where ORACLE_HOME like
/oracle/8.1.7
Previous Topic: OCCI link error, please help
Next Topic: Pro*C Compile Errors (7.3.4 to 8.1.7)
Goto Forum:
  


Current Time: Mon May 27 10:55:41 CDT 2024