Home » Infrastructure » Linux » Oracle - Linux RAW
Oracle - Linux RAW [message #192495] Tue, 12 September 2006 10:58
Messages: 24
Registered: September 2006
Junior Member

I wanted help in understanding the Oracle on Linux raw device.
U can also guide me to appropriate websites/Books.

The following are the steps I have performed on the Suse linux for the Oracle
1. Created the logical partition(/dev/system/test) with the reiserfs filesystem.
2. The /dev/system/test is mounted on /test
3. Bind the raw interface to it.
(raw /dev/raw/raw5 /dev/system/test)
4. Given the ownership and permission appropriately
chown oracle:oinstall /dev/raw/raw5
chmod 660 /dev/raw/raw5
5. When I tried to create the datafile, I got the below error:
SQL> create tablespace test32 datafile '/dev/raw/raw5' reuse size 1m autoextend on;
ERROR at line 1:
ORA-01119: error in creating database file '/dev/raw/raw5'
ORA-27041: unable to open file
Linux Error: 16: Device or resource busy
Additional information: 1

if I unmount the device /dev/system/test and then I am able to create the datafile.

>>> Wanted to confirm whether this is the known behaviour ?

II) After creating the datafile in the unmount state (associated block device), I am not able to mount /dev/system/test again. To mount it again, I have remove the datafile and then i am able to do it.

Please let me know if this is the known behaviour (i.e., Oracle doesnot allow the associated block device (i.e., in this case /dev/system/test) to be in the mounted state.

I tried the same thing on HP-UX [Created lvol/rvol using lvcreate]. I was able to create the datafile when the associated logical volume(lvol) was mounted.

your help is greatly appreciated.

~ Balu
Previous Topic: Oracle On Linux
Next Topic: An issue with Unix cron
Goto Forum:

Current Time: Wed May 22 19:55:56 CDT 2024